O2 Exchange Degraded Performance

Incident Report for O2 exchange

Resolved

The issue has been resolved and all systems are operating normally. We apologize for any inconvenience.
Posted May 18, 2026 - 18:14 UTC

Investigating

Some users may experience slower than usual response times or intermittent issues. Our team is investigating and working to restore full performance.
Posted May 18, 2026 - 14:36 UTC