O2 Exchange Disruption

Incident Report for O2 exchange

Resolved

The issue has been resolved and all systems are operating normally. We apologize for any inconvenience.
Posted May 27, 2026 - 21:41 UTC

Investigating

We are currently investigating reports of issues affecting the O2 exchange. Our engineering team has been alerted and is actively working to resolve the issue. We will provide updates as more information becomes available.
Posted May 27, 2026 - 21:31 UTC